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Welcome to Analyze 11.0, a robust, powerful, and practical research software for advanced biomedical imaging visualization, manipulation, 
and measurement.  Analyze features integrated, complementary tools for fully interactive multi-dimensional display, processing, segmentation, 
registration, and measurement of biomedical imaging modalities including MRI, CT, PET, SPECT, ultrasound, and digital microscopy.  It has been 
designed and carefully programmed to be highly efficient and user-interactive, performing powerful 3-D image processing and display operations in 
seconds.  The applications of Analyze are broad in scope, wide in scale, and penetrating in impact. 

Installation Instructions
Windows

Table of Contents

I. Installing Analyze 11.0 on Windows Systems....................................... 3
System Requirements.......................................................................... 3
Uninstalling Previous Versions of Analyze............................................ 3
Analyze 11.0 Installation....................................................................... 4
BIRlic License Management and Analyze Licenses............................. 7
Analyze License Files........................................................................... 7

II. Analyze Licenses..................................................................................... 8
Requesting a License File.................................................................... 8

III. Analyze License File Installation.......................................................... 9
Installing a Node-Locked License......................................................... 9
Installing a Floating License - Server.................................................... 9
Installing a Floating License - Client................................................... 10

IV. Dongle Installation............................................................................... 11

V. Running Analyze 11.0............................................................................ 12
Running the Analyze Program............................................................ 12
Analyze Patch Updates...................................................................... 12

VI. Analyze Basics..................................................................................... 13
Analyze 11.0 Resources..................................................................... 13
Analyze 11.0 Tutorial Data.................................................................. 13
Analyze 11.0 Image File Format Support............................................ 13

VII. Analyze Developers Add-On.............................................................. 14

www.analyzedirect.com


Analyze 11.0 Installation Instructions 3www.analyzedirect.com

Analyze 11.0 requires the following minimum PC configuration:
•	 Windows 7, XP or Vista (32- or 64-bit)
•	 Intel Core or comparable processor
•	 Network card
•	 CD-ROM drive

*Analyze requires RAM equal to twice the size of the data set being processed (e.g. a 256 MB data set 
requires at least 512 MB of RAM).

Before installing Analyze 11.0, it is recommended to uninstall any previous Analyze versions resident 
on your system. Otherwise, make sure to choose a new directory for Analyze 11.0 during installation. To 
uninstall previous versions of Analyze:

1.	 Open the Windows Control Panel (Start > Control Panel) and select Programs and Features.

2.	 Select the previous version of Analyze and click Uninstall. A dialog box will be returned requesting 
confirmation, click Yes. The previous version of Analyze will now be removed from your system.

3.	 Navigate to your C: drive and delete the C:\BIR folder.

note	 If you choose not to uninstall your previous version of Analyze, you 
will need to create a new folder on your C: drive named BIR10 before 
proceeding. During Analyze 11.0 installation, set the ‘Destination 
Folder’ to this new C:\BIR10 folder by clicking the ‘Change’ button.

•	 2 GB RAM*
•	 24/32-Bit graphics capability
•	 At least 450 MB disk space

System Requirements

Uninstalling Previous Versions of Analyze

I. Installing Analyze 11.0 on Windows Systems
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The InstallShield Wizard program will lead you through the complete Analyze 11.0 installation process 
(including optional components, such as the AVW Developers Add-On). To begin the installation process:

1.	 It is recommended to close all active programs on your desktop.

2.	 Insert the Analyze 11.0 Installation CD into your computer. 

3.	 Once the Installation CD is inserted, the InstallShield Wizard for 
Analyze 11.0 should automatically open.

4.	 The InstallShield Wizard opens to a ‘Welcome’ screen. Click 
Next to begin the Analyze 11.0 installation.

5.	 License Agreement: Please read the End-User License 
Agreement for AnalyzeDirect Software and select ‘I accept’ or ‘I 
do not accept’. If you select ‘I do not accept’, Analyze will not be 
installed. Click Next.

6.	 Destination Folder: The default location for installation is C:\BIR (when Windows is installed on the 
C: drive); it is recommended to leave this as the destination folder. Click Next.

	 If the InstallShield Wizard does not run 
automatically, open a Windows Explorer 
window and navigate to the ‘My Computer’ 
location. Locate the CD drive that shows 
‘Analyze_11.0’ and select ‘Auto Play’.

Analyze 11.0 Installation

I. Installing Analyze 11.0 on Windows Systems
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7.	 Setup Type: You may choose from the following setup types:

Required Disk Space

Analyze with Tutorials (Typical) 
Installs Analyze 11.0, the Analyze Tutorials, and ITK Extension* 173	 MB

Analyze Only (Minimum)
Only installs Analyze 11.0 125	 MB

Customized Analyze (Custom)
Installs Analyze 11.0 and permits selection of six optional components 
on the next screen:

-- AVW Developers Kit 60	 MB
-- AVW Examples in C and TCL 536	 KB
-- Data for AVW Examples 16	 MB
-- Analyze Tutorials 41	 MB
-- ITK Runtime Extension 6.7	 MB
-- ITK Developers Kit 944	 KB

If you plan to use the Analyze Developers Add-On, choose the Customized Analyze (Custom) 
setup type and click Next. The screen that follows will allow you to deselect any components you do 
NOT wish to install before proceeding with installation.

For most users, it is recommended to choose the Analyze with Tutorials (Typical) setup type. 

8.	 Once you have selected your setup type, click Next.

   *	 The ITK Extension component installs additional filtering, segmentation, and registration modules in 
Analyze that have been developed with functions from the ITK Library.

	 The Analyze Developers Add-On requires a special license file. To learn more about this Add-On, and 
to find out if your license file provides access, please refer to the Analyze Developers Add-On section 
at the end of this document. 

I. Installing Analyze 11.0 on Windows Systems
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9.	 Ready to Install the Program: Verify that the ‘Current Settings’ are accurate, 
then click Install.

10.	 Analyze 11.0 will now be installed in the C:\BIR directory. During installation, 
an Analyze 11.0 shortcut icon will be placed on your Desktop.  A Mayo Clinic 
Analyze folder will also be added to the Windows Start > All Programs menu.

11.	 When the InstallShield Wizard notifies you that installation is complete, click Finish. Note 
that if the Start License Tool option is selected, the BIRlic Tool will automatically open. 
To request a license, please follow the instructions in the next section of this document. 
Analyze Licenses.

I. Installing Analyze 11.0 on Windows Systems
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Analyze 11.0 uses the BIRlic license management system for Analyze validation and runtime license 
administration. The BIRlic license management software can be found in the C:\BIR\BIRlic-11.0 directory. 
BIRlic administers two types of Analyze licenses – node-locked and counted floating licenses.

A node-locked license will allow Analyze 11.0 to be run on one system only.  With a node-locked license, all 
license file administration is handled local to the specific system.  Additionally, on Windows systems the BIRlic 
license manager does not need to be configured for a node-locked license.

A floating license allows one system to act as a license server, “floating” the license across a network to a 
client system. Any client system with access to the license server can check out a license if one is available. 
Note – if only one floating license is purchased, two or more client system cannot run Analyze simultaneously.

For information on license pricing and options, please contact sales@analyzedirect.com.  

Your license will be stored in the C:\BIR\BIRlic-11.0\Licenses directory in a file named AnalyzeDirect.lic. 
During Analyze 11.0 installation, a default AnalyzeDirect.lic license file is placed in this Licenses directory.

The default AnalyzeDirect.lic license file MUST BE REPLACED by a system-specific license file, 
otherwise Analyze 11.0 will not run!

Once your AnalyzeDirect.lic license file has been generated, you will be notified by AnalyzeDirect via e-mail. 
To retrieve your license, please refer to the Analyze License Installation section and follow the instructions 
for your license type. If you are unsure what type of license you have, or encounter any difficulties with license 
file installation, please contact support@analyzedirect.com.

	 Windows users can also purchase a dongle as an add-on to their node-locked license. A dongle is a USB 
device that allows you to easily move the license between different Windows computers.

note	 All 30-day evaluation license files are node-locked licenses.

Analyze License Files

BIRlic License Management and Analyze Licenses

II. Analyze Licenses
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A system-specific license must be installed before Analyze 11.0 will run. You can obtain this license 
file from AnalyzeDirect. 

In order to generate your license file, AnalyzeDirect must receive two pieces of information specific to 
the computer: 1) the Host Name and 2) the Host ID.  The instructions below will explain how to send this 
information to AnalyzeDirect.

1.	 Open the BIRlic Tool (Start > All Programs > Mayo Clinic Analyze > BIRlic Tool).

2.	 The BIRlic Tool will open to the System Info tab (figure 1).

3.	 Click on the License tab (figure 2). 

4.	 Click the Request License button.

5.	 Your Host Name and ID will be automatically populated for you. To submit a license request, you must 
enter your Company, Name, Email and Phone. The Comments field is optional.

6.	 Click the Send Request button.

7.	 A dialog will appear once your license request is submitted (figure 3). If you are unable to submit 
a request, please send the information in the license request form, along with your system type to 
validate@analyzedirect.com.

8.	 Once AnalyzeDirect receives your system 
information, a license will be generated, and you 
will be notified via e-mail. To retrieve and install 
your license, please refer to the instructions for 
your license type (node-locked or floating) found 
under the section entitled “Analyze License 
Installation” on page 9.

Figure 1

Figure 2Figure 3

Requesting a License File

II. Analyze Licenses
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Once you have been notified by AnalyzeDirect that your AnalyzeDirect.lic license file has been 
generated:

1.	 Open the BIRlic Tool (Start > All Programs > Mayo Clinic Analyze > BIRlic Tool).

2.	 Click on the License tab. 

3.	 Click the Auto Retrieve button. A dialog will be returned telling you that your license file has 
been retrieved successfully (figure 4).

4.	 No further configuration is needed for a node-locked license on a Windows system. To run 
Analyze 11.0, please refer to the section entitled Running Analyze 11.0 on page 12.

Configuring a floating license server -

Once you have been notified by AnalyzeDirect that your AnalyzeDirect.lic license file has been 
generated:

1.	 Open the BIRlic Tool (Start > All Programs > Mayo Clinic Analyze > BIRlic Tool).

2.	 Click on the License tab. 

3.	 Click the Auto Retrieve button. A dialog will be returned telling you that your license file 
has been retrieved successfully (figure 5). To complete the license install process, start the 

Figure 4

Figure 5

Installing a Node-Locked License

Installing a Floating License

note	 If license retrieval is unsuccessful, please contact AnalyzeDirect 
at validate@analyzedirect.com or +1 913-338-2527

note	 If license retrieval is unsuccessful, please contact AnalyzeDirect 
at validate@analyzedirect.com or +1 913-338-2527

III. Analyze License File Installation
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Configuring a floating license client -

1.	 Open the BIRlic Tool (Start > All Programs > Mayo Clinic Analyze > BIRlic Tool).

2.	 Click on the License tab. 

3.	 Click the Auto Retrieve button. 

4.	 A dialog will be returned telling you that the server does not match the server listed, click Yes 
to confirm that it is a floating license client (figure 7).

5.	 In the window returned, enter the Host ID from the floating license server system (figure 8). 

6.	 No additional configuration is necessary on client systems. You should not start the BIRlic 
license server on the client systems. For more information on running Analyze 11.0, please 
refer to the section entitled “Running Analyze 11.0” on page 12.

If at any point you encounter difficulties getting your floating license server or client systems up and 
running, please contact support@analyzedirect.com.

Installing a Floating License

BIRlic license server as described in the steps that follow. 

4.	 Select the Server tab.

5.	 Click Install Service [A] to install the BIRlic license server as a Windows Service that will 
automatically start the license server at system boot. Click Yes when prompted.

6.	 Once the Service has been installed, click Start Service [B] to start the license server service. 
Click Yes to start the ‘BIRlic Server as a Service’ on this computer.

7.	 Once the Service has been started. The BIRlic license server configuration is now complete. 
To configure client systems, please follow the instructions below. 

Figure 6

Figure 7

Figure 8

III. Analyze License File Installation
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The following instructions are for users who have purchased a dongle for their Windows node-locked 
license.

Please DO NOT attach the dongle to the system until directed to do so in the instructions below.

1.	 Install Analyze 11.0 according the instructions found in the section entitled “Installing Analyze 11.0 
on Windows Systems”. 

2.	 Ensure that your dongle is NOT attached to your system. The dongle driver must be installed before 
attaching the dongle to your computer.

3.	 The dongle driver installation program is shipped with Analyze 11.0. To find the program, navigate to 
the following directory based on your version of Windows:
•	 Windows (32-bit) – C:\BIR\BIRlic-11.0\PC_NT\USB_Dongle
•	 Windows (64-bit) – C:\BIR\BIRlic-11.0\PC_NT64\USB_Dongle

4.	 Double-click on the Install.exe found in your respective directory to begin the dongle driver 
installation.

5.	 In the Security Key Installation window that opens, check the USB Dongle option. 

6.	 A dialog box will be returned asking that you do NOT attach the dongle until the installation is 
completed. Click OK to dismiss this window.

7.	 Select Standalone (if not already selected) and then click Begin Install.

8.	 Once the installation process is complete, a notification will be returned, click Close to dismiss the 
window.

9.	 Attach the dongle to your computer’s USB port. In Windows XP, the Add Hardware Wizard will 
automatically open; follow the instructions in the Wizard to complete driver installation. In Windows 7 
and Vista, the Add Hardware Wizard will run silently in the background - no further steps are required.

10.	 Next, retrieve the AnalyzeDirect.lic license file via the BIRlic Tool (Start > All Programs > Mayo 
Clinic Analyze > BIRlic Tool).

11.	 Click on the License tab. 

12.	 Click the Auto Retrieve button. A dialog will be returned telling you that your license file has been retrieved successfully.

13.	 Analyze 11.0 will now run when the dongle is attached to your computer. Repeat these installation steps on every 
computer on which you plan to run Analyze 11.0 using the dongle-based license.

	 If you did attach your dongle before 
installing the driver, please remove it and 
follow steps 3 and 4 to open the dongle 
driver installation program.  However, 
instead of proceeding with step 5, select 
the ‘Uninstall’ option and click ‘Begin 
Uninstall’. Once uninstall is complete, 
repeat the steps above.

IV. Dongle Installation
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Once you have installed Analyze 11.0 and your AnalyzeDirect.lic license, you are ready to run the 
program.

1.	 To open Analyze 11.0, select Start > All Programs > Mayo Clinic Analyze 
> Analyze 11.0 or click on the Analyze 11.0 Desktop shortcut icon.

2.	 The first time Analyze 11.0 opens, the End-User License Agreement for 
AnalyzeDirect Software will appear. Please read the agreement carefully 
and then click I Accept or Exit.  Note, if you click ‘Exit’ Analyze 11.0 will not 
open.

3.	 Once you have accepted the End-User License Agreement, Analyze 11.0 
will open.

	 If Analyze 11.0 fails to open, please 
contact support@analyzedirect.com.

As with most software products, the process of bug fixing and minor maintenance between versions is an 
ongoing process. Analyze has all such fixes available in the form of a patch. Patches can be automatically 
downloaded and installed by selecting the Help > Analyze Update option from the main Analyze window. 

If it is detected that a new patch is available when you select Help > Analyze Update, a window will appear, 
asking if you wish to download the update. Click Yes to download and install the patch update.

It is recommended that you check for new patch updates the first time you run Analyze 11.0 and then once 
each month.

Running the Analyze Program

Analyze Patch Updates

V. Running Analyze 11.0
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There are several excellent resources available to help you get started with 
Analyze 11.0. 

To quickly learn the basics of Analyze, we recommend that you work through 
the Analyze 11.0 Essential Training Guide – found on the silver Resources CD 
included with your software package. The Essential Training Guide contains a 
series of short exercises covering the most commonly used Analyze features 
and functions.

The Analyze Tutorials (optional component during installation) and the Analyze 
User’s Guide, both available from the Help menu in the main Analyze window, 
are other excellent resources, providing detailed information about the Analyze 
modules.

Analyze Demos (help movies) can be viewed by selecting Help > Analyze 
Demos. You will be directed to a link with a list of specific Help Movies.

Analyze 11.0 Resources

The tutorial data used in the Analyze 11.0 Essential Training Guide exercises 
and the Analyze Tutorials can be found on the silver Resources CD. To install 
the tutorial data from the Resources CD, do the following:

1.	 Insert the silver Resources CD into your computer.

2.	 Open Analyze 11.0.  From the main Analyze window select Help > 
Analyze Tutorials.

3.	 In the Tutorials window, click the Install Tutorial Data button.

4.	 In the window returned, specify the file path to the TutorialData folder on 
the Resources CD (e.g. D:\TutorialData).

5.	 Click Install. The tutorial data will be copied into the C:\BIR\images\
TutorialData directory.

Analyze 11.0 Tutorial Data

Please note: Analyze does not automatically configure all supported file formats. This keeps module startup time to a minimum, loading only those 
image formats that you need to use with Analyze for your purposes. To configure and load all supported file formats in Analyze, use the Import/
Export module’s External Libraries tool.  Instructions on how to use the External Libraries tool can be found in the Essential Training Guide, 
Exercise 3: Switching on Support for Additional Formats.

Analyze 11.0 Image File Format Support

VI. Analyze Basics
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The Analyze Developers Add-On allows software developers to extend the 
capabilities of Analyze by developing their own macros and modules, using the 
AVW (A Visualization Workshop) image function library upon which Analyze is 
built.  The library is robust and includes over 600 imaging functions that can be 
called at a C-language level. 

Note – the Analyze Developers Add-On assumes you are familiar with 
programming.

To get access to AVW development capabilities, you must select the ‘Custom’ 
install during Analyze 11.0 installation. The Developers Add-On also requires 
a special AnalyzeDirect.lic license file that will allows access to the AVW 
development capabilities. All 30-day evaluation license files provide access to 
the Developers Add-On.

If you already own an Analyze license and would like to evaluate the 
Developers Add-On, please contact sales@analyzedirect.com.

During the ‘Custom’ install of Analyze 11.0, the AVW Programmers Guide, 
AVW Reference Manual, and AVW Quick Reference Guide should have been 
installed in the C:\BIR\AVW-11.0\Manuals directory.  You can also find these 
documents under Start > All Programs > Mayo Clinic Analyze > AVW 
Developers Kit.

The best place to start practicing with the AVW functions is with the examples 
provided in the C:\BIR\AVW-11.0\Extras directory. This directory contains a 
number of example source files, both in C and in Tcl/Tk, for common Analyze 
imaging tasks (like rendering, segmentation, etc.). Note that while Analyze 
uses Tcl/Tk, the AVW library is interface-independent, allowing developers 
to work in almost any development environment.  If you do want to know 
more about Tcl programming, we recommend starting with the ‘Bible’ of Tcl/
Tk - “Practical Programming in Tcl and Tk” by Brent Welch. This comes with 
a CD that you can load on to your computer, which includes a full Tcl/Tk 
implementation and many examples.

The .tcl scripts contained in the C:\BIR\AVW-11.0\Extras subdirectories are 
full source code scripts that can be run, however, you will need to setup the 
Tcl/Tk environment such that these scripts can find the Tcl/Tk files needed 
to execute. The develop_env.bat script included in the C:\BIR\AVW-11.0 
directory provides an example of a script that can be used to set these 
development environment variables.

VII. Analyze Developers Add-On
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