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Introduction

Cranial implants of different types are used by neuroscientists to record, stimulate, or block neural signals in animal studies. In addition, cranial

implants may eventually be used in a clinical context as neural prosthetics or brain-machine interfaces to treat neurological disorders.

Previous cranial implant designs have experienced several issues due to the materials used in implants and the methods used to attach implants
to the skull. Mulliken et al. have designed custom-fit cranial implants that solve many of these problems'. This new implant design features a
custom fit based on skull structure as determined from segmentation of MR scans of each individual animal. Segmentation of the skull from MR

obviates the need to acquire CT data and register it to the MR data.

The goal of this guide is to provide instructions to segment the cranium from the surrounding soft tissue (brain and skin) using a T1-weighted
MRI data set, create a target vector object at a given stereotaxic coordinate to specify the position and orientation of the implant in relation to

the skull, and to generate surface files for both the cranium object and vector object using Analyze.
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Segmentation of Skull Surface and Vector Creation

Skull Segmentation #.  Thresholds - Volume Render — — O
Minimum [] Histogram Mazximum
Cortical bone has no signal in T1-weighted MRI, therefore voxels representing 257 | T /4095
the skull have similar signal values to those representing the airspace or B -L\\‘Hange @ Volume () DataType
background in the image data. We are able to leverage this characteristic to
Render Done

isolate the skull from the head using Analyze. Once the skull is segmented the
target vector can be easily created using the object fabrication tools provided

by the Volume Render module.
Load the image data into Analyze using File > Load.
Select the loaded data and then open Display > Volume Render.

In the Volume Render module open the Preview @4{ window and the Thresholds w,ﬂ window.

THRE=SH

In the Thresholds window increase the minimum threshold value using the double-ended slider. Note that the image displayed in the
Preview window will automatically update. Adjust the value until the airspace is removed from the image in the Preview window and the soft
tissue is displayed.
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It reqUiredl adeSt the pOSition of A Preview - Volume Render = Fa Preview - Volume Render
the data by clicking and dragging
the image in the Preview window

to a new orientation.

Preview Always On Top Preview Always On Top
Ratio @ 1:1 31 Ratio @ 11 031

O 21 O 41 O 21 O #1

Size Auto — Size Auto —
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Next select Tools > Manipulate > Threshold Tool. In the . ) )
Fa Preview - Volume Render

window set Change to Object Map. Note the Objects window

will automatically open.

Next use the drop-down menu to change the Defined Object

to ***New*** and then click the Threshold Volume button.

All rendered voxels (those representing the soft tissue, brain

parenchyma, etc.) will be assigned to a new object, Object_2.

All voxels outside the specified threshold range, those with a
low grayscale signal value (background and cortical bone), will

remain as part of the Original object.

Note the appearance of the image displayed in the
Preview window will change from white to red once the

process is complete.

Close the Threshold Tool.

Preview Always On Top
Ratio ® 11 (31
O 21 O 41

Size Auto —
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From the Objects window select Morph

#% Morph Object-.. - F

the Morph Object button. Object

In the Morph Object window returned,
set the Object to Object_2, set the
Operation to Fill Holes, set the Defined
Object to the input object, Object_2,
and then click Morph.

Confirm that you would like to conduct
the specified fill operation by clicking
Fill Holes in the verification window
that appears. The algorithm will now
fill any spaces (those left by the voxels
representing cortical bone) in the
segmented head object (Object_2),

creating a solid object.

Object: Object 2 ~

Operation: Fill Holes =

Fill Type
(3D (20 (@) 3pass2D
(®) Transverse () Coronal () Sagittal
Connectivity

(®) 4-connected (") 8-connected

Defined Object: Object 2 ~

Marph Dene

Once the process is complete close the Morph Object window.

Volume Render

; Filling holes in 'Object_2" (Object #2)7

Cancel
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In the Object window set the Object A e ol S - o At Preview - Volume Render = =

to Original and then set the Display
of the object to Off.

Use the Threshold window to invert
the selected voxels. Set the minimum
threshold level to the lowest possible
value and then reduce the maximum
threshold value until only the voxels
with a low signal value, those

representing the skull, are visible.

Note that the voxels representing the

airspace surrounding the head are

not visible as they are assigned to the T ) Ahways On Top P Ve omTas
. . . . Ratio ® 1:1 O 31 Ratio ® 11 O3

Original object, the display of which = 5 S e

is disabled. Click the Render button; Size Auto — Size_Auto —

the rendered skull will be displayed

in the main Volume Render window and the current object status updated for all tools in the module.

For this procedure we are only concerned with the upper skull, therefore we can remove the lower skull and noise from the current object.
Select Tools > Manipulate > Trace. In the Trace tool choose any of the region definition tools from the tool palette on the right-hand side

and then draw a closed trace around the region to be removed.

. Select the Flood Fill Tool and then click in the region to be removed. If the region is defined by a closed trace then this region
gl only will appear as a solid red region. If the entire image becomes red click the Undo button and repeat the region definition step,
ensuring the trace is closed. With the Defined Object set to Original click the Change Memory button. All voxels in the 3D image positioned
under the defined 2D region will be reassigned to the Original object. Because the display of the Original object is switched off, these

voxels will be removed from view. Close the Trace tool.
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In later steps 3D surface files of the skull will be generated for P : :
£ Preview - Volume Render

rapid typing, therefore it is necessary to remove any spatially
disconnected voxels from the skull. This can be achieved quickly

by performing a 3D region grow to isolate the skull.

Select Tools > Manipulate > Connect Tool. In the Connect
Tool click on the skull to establish a seed point, set the Defined
Object to ***New***, and click Connect. The tool will perform a
3D region grow assigning connected voxels into a new object.
These voxels will be assigned to Object_3, and the image in the
preview window will update from Red to Green, while spatially

disconnected voxels will remain red. Close the Connect tool.

At this point we can remove (delete) Object_2 from our object
map by reassigning it to the Original object.

) ) ) ) ) Reassign
In the Objects window click on the Reassign Object(s) Object(s)

button. In the Reassign Object(s) window returned select
Object_2 and reassign it to the Original object. Click Apply to

perform the reassignment and then click OK to close the window.

Change the name of Object_3 to Skull by updating the Name field

for the object in the Objects window. Click the Add Object  Add Preview Always On Top
Sl Ratic ® 1:1 3 31

O 21 O 41

button to create a new object for the target vector and

change the name of the new object to Line. Change the color of
. . . . . Size Auto —
this object to red. Click Done to close the Objects window.

At this point you can also close the Preview window and the

Thresholds window.
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Target Vector Creation #1 Intensity - Volume R.. - ©

. e . . . Type: Object Color =
Select View > Intensities > Loaded Volume. In the Intensity window set Type to Object J
. Mode | ocal Ma/Min =
Color and then set Mode to Local Max/Min. o B & i "
() Show All () Enabled Only (® Color Enabled
This Object Color display mode will display the segmented skull over the 2D grayscale slice L] Invert Show Mow

data, which is necessary for optimal target vector placement.
Done
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Select Tools > Display > Ortho Sections. It may be necessary to
increase the display size of the data. To do this, right-click on the

rendering, then select Size and then the desired display size.

Note: the segmented skull can be seen as the green region of the 2D slices.

Done
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Select Tools > Manipulate > Fabricate. The Fabricate 4 e e
tool will facilitate the creation of the target vector object. B e
In the Fabricate tool set the Shape to Line. ecim e
) 2-D (_) Dot (_) Cube (_)Box 7 Filled
® 3-D (@ Line () Sphere () Ellipsoid ;
The Ortho Sections tool is linked to the Fabricate tool
Alt
when both tools are open and can be used to accuratel
P y StartX| 136 _L|
place the first point of the 3D Line object which will Start'y| 284 |
become the target vector object. Use the Ortho Sections StartZ| 189 L1
tool to navigate through the image data or use the R 10 |
- . . . End Y| 250 |
rendering to adjust the XYZ starting position of the 3D s |
Line. Note that the position will interactively update in the
Fabricate tool.
Once the first point of the
3D Line is positioned on the
skull, the second point of the
3D Line can be positioned
using the Fabricate tool. Set
Change to Object Map, then N % @
e P Ns
set the Defined ObJeCt to Change: (_) Volume (® () Both
Line, and then click Create. Defined Object: Line ~ B s
Note that the target vector Create Undo Done

will appear as a thin red
line best seen on the 2D

orthogonal slice data.

Close the Fabricate tool and the Ortho Sections tool and save the object map by clicking File > Save Object Map. The object map will be

saved and used to generate surface files as described in the next protocol.
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Surface Extraction

The goal of this procedure is to convert the skull and target vector objects
generated in the first procedure from voxel-based volume image data to
explicit surface description files. For this purpose Analyze will efficiently
and accurately extract and represent a surface from the segmented

objects, exporting these surfaces as STL files.
Select the data and then open Segment > Surface Extractor.

In the Surface Extractor module load the object map (File > Load Object

Map) saved in the first procedure.

Select Generate > Extraction to open the Extraction Parameters window.

In the Extraction Parameters window select the Objects button to open

the Objects window.

Set the Line (target vector) object to Off. The only object that should be
set to On is the Skull.

Select Objects for Surface Extraction
Criginal (@) Off () On
Skull () Off (®) On
Line (@ Off () On

Done

it Objects - Surface Extractor = =
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In the Extraction Parameters window make sure that the Scaled
Coordinates option is checked. This will ensure that the surface file is

generated in real world coordinates and not in voxel units.

Next click the Extract button. When the process is complete a window
will be returned informing you of the number of polygons generated

for this surface. This will initiate the surface extraction process.

Now click Done to dismiss the window.

#4 Extraction Parameters - Surface Extractor

Threshold... || Objects...

AdaptDeform | Marching Cuhesl Cu:untu:uurs.l Thin Wall I

Find Budget
Specify Budget |0

lterations 10

Cube Edge Size |3

caled Coordinates
'h: anced...

Preview...

_:

Extract Reset

Done
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Next click the Save Surfaces

= button. In the Save Surfaces window select the File button. =
[=] #4 Save Surface .. — O

Qutput Surface

C/Users/Michael/Des |+

File Skull

In the window returned, navigate to a destination to save the surface file, then name the file Skull
and click Save. The window will close. In the Save Surfaces window set the Format to 3D Systems

(.stl) by selecting this option from the drop-down menu and then click Save. The skull surface file
Format 3D Systerns (.stl) =

will be saved out of Analyze in the STL surface description file format.
Right Handed

In the Objects window, set the Skull object to Off and the Line object to On.
Save h Cancel

Repeat the previous steps to extract and save the surface out of Analyze in the STL surface

description file format. Remember to name this surface file Target Vector or Line.
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