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Bone mineral density (BMD, mg/cm3) is an important measure in the evaluation of osteoporosis. The X-ray attenuation coefficients produced 

in micro-CT are converted to an equivalent BMD value. This conversion is accomplished by using phantoms (liquid K2HPO4 or solid resin-

embedded hydroxyapatite) of known densities to generate a calibration line1,2.

Micro-CT provides a non-destructive way of measuring bone mineral density in pre-clinical studies. It has been shown to correlate to the 

gold standard of ash content measurements when beam-hardening artifacts are minimized3,4. The ovariectomized rat is commonly used as 

an animal model of osteoporosis and osteopenia for preclinical studies5. Thormann et al.6 quantified ossified tissue in the femoral fracture 

gap of ovariectomized (OVX) and control (SHAM) rats. Decreased BMD has also been observed in ovariectomized sheep7 and goats8.

This guide will show how to calibrate micro-CT data to bone mineral density (BMD) values, segment mineralized bone from control and 

OVX data, and measure bone volume and mean BMD for a volume of interest in Analyze. Sample phantom, OVX, and control data can be 

downloaded from http://analyzedirect.com/data/.

Introduction

http://analyzedirect.com/data/
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The calibration of bone data to BMD values using a phantom comprises three steps. First, the scan of the phantom inserts is sampled at 

each phantom density to determine the mean grayscale intensity value of each phantom insert. Next, these grayscale intensity values are 

graphed against the known phantom densities to form a calibration curve. Last, the bone data is calibrated using the slope and intercept of 

the linear calibration curve. The phantom should be scanned using the same protocol as was used for the bone data. 

BMD Calibration
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Sampling of Phantom Densities
Load the data set containing the phantom inserts into Analyze 

using the Load module (File > Load). Select the phantom data set 

in the Analyze workspace and open the Region of Interest module 

(Measure > Region of Interest). 
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In order to sample the mean density of each phantom insert, we will 

need to create an object map. Using the slice slider bar, navigate 

to the first slice where the phantom inserts appear. From this slice, 

move forward several slices in case of some artifact at the end of the 

phantom. Note that for this phantom, a region of zero bone mineral 

density (0 mg HA / cm3) will be defined where there is no insert.

Using the oval draw tool, hold down the Ctrl key, click in the 

center of the region shown in the figure and drag outward 

to create a circular object of a size that would encompass most of an 

insert but not go all the way to the edges. It is easiest to first define 

the region of negligible bone density, and then define subsequent 

regions in order of increasing density in a counterclockwise direction, 

as shown by the red arrow.
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To define the other regions, set Object to Define to *** New ***.

Use the Copy Region tool to copy the circular region to 

the other phantom inserts. To use this tool, click in the 

first object and drag to place a circle on the next insert. Once 

all inserts have been defined by circular regions, rename the 

objects from the objects window (View > Objects). Choose 

to Control by Attribute and change Attribute to Name. Then 

rename each object with its known density.
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Next we need to extend these regions throughout the length of the inserts. This can be done using the 

Propagate Regions tool. To determine the last slice where the objects will be defined, navigate to the 

last slice where the phantom inserts appear and move back several slices. To determine the increment, 

subtract the slice number where the objects are first defined from the number of the last slice where 

the objects will be defined. Open the Slice window (Generate > Slice) and set Slice to the first slice 

where the objects are defined. Set Increment to the value just determined from the subtraction step.
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Click the Copy Regions Forward button to copy the regions to the chosen slice. Now 

the regions are defined on the first and last slice, and the Propagate Regions tool 

will connect those regions throughout the slices in between. Open the Propagate Regions 

tool (Tools > Propagate Regions). Click Select All to select all the objects, and then click 

the Propagate Regions button. Use the slice slider to check that the regions have correctly 

been propagated through the inserts. Save the object map (File > Save Object Map).
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The next step is to sample the phantom objects to determine the mean 

grayscale intensity value of each. Open the Sample Options window 

(Generate > Sample Options) and set the following parameters:

•	 Sample Type to Object(s)

•	 Select All Objects except Original

•	 Summing to On
•	 Sample to All Slices
•	 Sequence Display to Off
•	 Decimal Places to 4
•	 Log Stats to On
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Click the Configure Log Stats button, and deselect Area and Volume, as the mean intensity 

value is the only measurement of interest. Click Done to close the ROI Stats window.
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In the Sample Options 

window, click Sample Images 

to begin the measurement. 

The results will appear in the 

ROI Stat Log window.

Click the Save button, or right-

click and select Save Log or 

Save Log As to save the log as 

a .stats file.
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Determination of Calibration Curve
Now that we have the mean intensity value for 

each phantom of known density, we can generate a 

calibration curve. Open Microsoft Excel or another 

spreadsheet software and import the .stats file 

saved in the previous step as a space-delimited 

file. In Excel, go to File > Open, and set the drop-

down menu to All Files instead of All Excel Files. 

Open the .stats file, and the Text Import Wizard 

will be launched. In the wizard, set the data type to 

Delimited and click Next.
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In Step 2 of the Text Import Wizard, select 

Space as the only delimiter, then click Next.
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In Step 3 of the Text Import 

Wizard, click Finish to import 

the .stats file.

Next we will generate the 

calibration curve. Right-click 

on the column containing 

the mean and insert a new 

column. Name the new 

column BMD and label the 

units mg HA / cm3. Enter 

the known insert densities 

into this column. Select the 

values in the BMD and Mean 

columns and create a scatter 

plot with only markers (Insert 
> Charts > Scatter > 
Scatter with only Markers).
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Right-click on the data series and 

select Add Trendline. In the Format 

Trendline window, check the boxes for 

Display Equation on chart and Display 

R-squared value on chart. The default 

trendline is linear, so the regression 

type does not have to be changed. 

The error bars in the calibration curve 

shown here represent the standard 

deviation of the mean intensity value 

of each phantom insert, as returned by 

the measurement algorithm. 
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Calibration of Bone Data
Note that the bone data consists of grayscale intensity 

values in Hounsfield units (HU), which are represented 

by the y-values in the linear calibration curve. In order to 

convert to BMD values, we will need to solve for x in the 

regression equation. Doing so results in the following:

This equation will be applied to the bone data using the 

Image Algebra module. Open the Image Algebra module 

(Process > Image Algebra) and type the equation for BMD 

into the Output= box. Drag and drop the control bone data 

set from the Analyze workspace into the input port. 

Input - Intercept

Slope
BMD =
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Click the Output button and name the Output data set. Change the Data Type to 

Signed 16-bit.
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Click the Go button in the Image Algebra module to begin the processing step. To calibrate the OVX bone data set, select the data set and 

drag and drop it from the Analyze workspace into the Input port of the Image Algebra module. Click the Output button to name this output 

data set. Leave the Data Type as Signed 16-bit, and click Go in the Image Algebra module to process the new data set. Once processing of 

all bone data is complete, click Exit to close the Image Algebra module.
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Select the control bone 

data set that has been 

calibrated to BMD and open 

the Volume Edit module 

(Segment > Volume Edit). 
Select the Semi-Automatic 

tab and choose the Region 

Grow radio button. Move to 

a transverse slice where the 

cortical bone is well-defined, 

and click in the cortical bone 

to set a seed point. Adjust 

the threshold range so that 

it defines the bone. The 

maximum threshold value 

should be set to the highest 

possible value, and the 

minimum threshold value 

should be set by sliding the 

lower part of the threshold bar until the binary image shown describes the bone. If there is noise due to artifacts that are not spatially 

connected to the bone, it will not be extracted by the region grow algorithm and can be included in this binary image used to select the 

segmentation threshold range. Make a note of the threshold minimum chosen, as this value will be applied to subsequent data sets.

Bone Segmentation
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Click the Extract Object 

button to run the Region 

Grow algorithm and extract 

the bone.
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Object_2 can be renamed by clicking in the Name box and typing a new name. When you are satisfied with the segmentation, save the 

object map (File > Save Object Map) and close the Volume Edit module.

To segment the OVX bone data set, repeat the segmentation steps from this section, using the same threshold range as for the control data set.
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Bone Volume and BMD Measurement
The last step consists of measuring the volume of bone and the mean 

BMD. This is done in the Region of Interest module. Select the control 

BMD-calibrated bone data set in the Analyze workspace and open the 

Region of Interest module (Measure > Region of Interest). Load the 

object map from Volume Edit in the segmentation step.

Note: If the object map was saved in the same folder as the corresponding data 

set and with the same name, it will load automatically.

Open the Sample Options window to set the measurement parameters 

(Generate > Sample Options).

•	 Sample Type to Object(s)

•	 Select only the Bone Object

•	 Summing to On
•	 Sample to All Slices
•	 Sequence Display to Off
•	 Decimal Places to 4
•	 Log Stats to On
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Click the Configure Log Stats button and uncheck the Area measurement, then click Done to 

close the ROI Stats window.
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In the Sample Options window, 

click the Sample Images button 

to initiate the measurement 

algorithm. The results will 

appear in the ROI Stat Log 

window and can be saved to disk 

as a .stats file by right-clicking 

in the window and choosing 

Save Log or Save Log As, or by 

clicking the Save button.
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Repeat the measurement steps 

for the OVX bone data set.
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Note that the Mean value represents the mean BMD of the bone object, as the data set was calibrated to BMD. The results for the single 

OVX and control data sets measured here are a mean BMD of 690 mg/cm3 for the OVX condition and a mean BMD of 730 mg/cm3 for the 

control. The bone volume has not changed significantly. The .stats files generated from the Region of Interest module can be imported into 

Excel or other spreadsheet software as space-delimited files, as shown in the BMD Calibration section of this guide.

If you wish to make more complex measurements, such as separately measuring the BMD of trabecular and cortical bone, you may 

be interested in the Bone Microarchitecture Analysis Add-On. This Add-On is capable of segmenting cortical and trabecular bone 

and measuring common bone morphometric indices. Beyond BMD, the Bone Microarchitecture Analysis Add-On measures bone volume 

fraction, bone surface density, connectivity density, structure model index, trabecular number, thickness, and separation, second moments 

of inertia, various measurements of cortical porosity and more.

http://analyzedirect.com/analyze-add-ons/bone-analysis-add-on/
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