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The Image Edit module provides a number of manual segmentation tools.  This exercise will demonstrate how to segment grayscale data using the 
auto trace tool.  For a full overview of all the segmentation tools in the module, please review the Image Edit tutorial available from the Help menu in 
the Analyze window.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Edit module (Segment > Image Edit).

3.	 Open the Slice window (Generate > Slice), and use the slider bar to move to 
Slice 122.  

4.	 In the main Image Edit window, select the Auto Trace tool [A].  Position the cursor 
near the center of the brain and click to set a seed point.  The Image Edit window will 
automatically update to display Auto Trace parameters (figure 1).

5.	 Use the double-ended slider bar at the bottom of the window [B] to adjust the 
threshold range until a reasonable trace of the brain is obtained.  A threshold 
minimum of 34 and maximum of 129 works well for this data set.

6.	 Select the Delayed Flood Fill tool and place a fill point outside the auto-traced region 
(click on the background). 

7.	 Select the Auto Trace tool again and click Apply & Advance [C].  

8.	 A dialog box will be returned stating that 
the action modifies the loaded volume, 
click Change a Copy of the Loaded 
Volume.  The area outside the trace will 
be highlighted in red, and then the next slice will appear in the image display (the slice 
number can be seen in the lower left corner of the image display [D]).

9.	 Review the edited slice by opening the Edit Review Tool (Tools > Edit Review) 
(figure 2). 

10.	 In the main Image Edit window, you will notice that when the module advanced to 
slice 123 (step 8) the seed point and auto trace parameters set in step 5 were copied 
forward.  The trace should have automatically adjusted to the brain on this slice.  If 
not, the seed point may have been copied forward to an area outside the brain or to 
a voxel with a different grayscale value.  Use the Move button and adjust the seed 
point. 

note	 An edited version of the data set will 
be automatically saved to the Analyze 
workspace.

Figure 1

Figure 2

Exercise 28 : Image Edit Manual Segmentation of Grayscale Data
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11.	 If the trace needs no further adjustment and the Delayed Flood Fill point is still 
positioned outside the trace, click Apply & Advance and edit 19 more slices, finishing 
on slice 142. 

12.	 In the Edit Review tool, change the orientation to Coronal and then Sagittal, note the 
slice edits in these orientations (figure 3).

13.	 To create a rendering of the edited data complete the Additional Task.  

1.	 Continue to segment the data set until approximately slice 181 to remove the 
entire top of the head.

2.	 Close the Image Edit module.

3.	 Select the MRI_3D_Head0 data set in the Analyze workspace and then open 
the Volume Render module (Display > Volume Render). 

4.	 Open the Thresholds window (Display > Thresholds).

5.	 Set the Minimum threshold level to 50, then click Render.  The rendering 
will be displayed in the main Volume Render window (figure 4).

6.	 Close the Volume Render module before proceeding to the next exercise.

Figure 3

Figure 4

A
dd

iti
on

al
 T

as
k

28.1 Rendering Segmented Data

Exercise 28 : Image Edit Manual Segmentation of Grayscale Data
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As discussed in Exercise 13: Volume Render Advanced Controls, object maps are special image files that are used in Analyze to partition and 
identify structures as belonging to a particular segmented object.  This exercise will demonstrate how to create an object map containing manually 
segmented objects. 

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Edit module (Segment > Image Edit).

3.	 Choose File > Create Object Map.  The Objects window (View > Objects) will 
automatically be returned (figure 1).    

4.	 Click Add Object [A] to create a new empty object (Object_2). 

5.	 Change Name from Object_2 to Brain [B].  Click Done to dismiss the Objects 
window.

6.	 Open the Slice window (Generate > Slice), and use the slider bar to move to Slice 
122.  

7.	 At the bottom of the main Image Edit window, set Change to Object Map and choose 
Brain from the Defined Object drop-down menu [C]. 

8.	 Select the Auto Trace tool, the Image Edit window will automatically update to 
display Auto Trace parameters (figure 2).  

9.	 Position the cursor near the center of the brain and click to set a seed point.  Use the 
double-ended slider bar [D] at the bottom of the window to adjust the threshold range 
until a reasonable trace of the brain is obtained.  A threshold minimum of 34 and 
maximum of 129 works well for this data set.

10.	 Select the Delayed Flood Fill tool and place a fill point inside the auto-traced region 
(click inside the region).  

11.	 Select the Auto Trace tool again.  

12.	 Click Apply & Advance.  The next slice will appear in the image display (the slice 
number is displayed in the lower left corner [E]).

note	 If you did not set the ‘Change’ option to Object Map (step 7) the 
defined region will appear black in the Edit Review tool.

Figure 1

Figure 2

Exercise 29 : Image Edit Manual Segmentation and Object Map Creation



Analyze 10.0 Essential Training Guide 85

13.	 View the edited object map by opening the Edit Review Tool (Tools > Edit Review).   

14.	 Select the Previous option in the Edit Review tool.  The change can also be viewed by 
selecting the Sagittal option.

15.	 With the Auto Trace tool selected, continue to segment slices by clicking Apply & 
Advance in the main Image Edit window.  Segment the brain on 20 slices (to slice 142).

   

16.	 To save the created object map for use in other Analyze modules, choose File > Save 
Object Map.  Save the object map as xxx_mybrain.obj (where ‘xxx’ are your initials).

tip	 If the auto trace does not apply to a slice, or leaks to unwanted structures, try the 
following: 1) adjust the threshold range, 2) draw a limit after selecting the ‘Add Limit’ 
button, or 3) turn on the ‘Auto Limit’ option and adjust the ‘Gap Size’.  Additionally, 
the auto trace can be adjusted on a slice by moving the seed point with the ‘Move’ 
button selected.

1.	 In the Analyze workspace, select the MRI_3D_Head data set and open the 
Volume Render module (Display > Volume Render).  

2.	 Choose File > Load Object Map and load the xxx_mybrain.obj object map 
(saved earlier in step 16).

3.	 Open the Objects window (View > Objects).  Set Control by to Attribute 
and set the Display attribute to Off for the Original object.

4.	 Click Render.  You should see a rendering of the object you created in the 
Image Edit module.  

5.	 Use the Rotation window (Generate > Rotation) to generate different views 
of the object (figure 2).

Figure 1

Figure 3
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29.1 Viewing the Object Map in Volume Render

Exercise 29 : Image Edit Manual Segmentation and Object Map Creation
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The Morphology module applies 1-D, 2-D, or 3-D mathematical morphological transformations and object topology operations to a data set. This 
exercise will demonstrate the morphological segmentation tools available in the module by showing how to segment the brain from an MRI data set.

Figure 1

Figure 2

Figure 3

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Morphology module (Segment > Morphology).

3.	 From the Generate menu, open the Slice tool. Move the slice slider to slice 130.

4.	 Open the Step Editor window (Generate > Step Editor) (figure 1).

5.	 Click the Threshold button [A]. In the Step 1: Threshold window returned, set the 
Threshold Min to 65. Click Threshold Volume. In the window returned, select Change 
a Copy of the Loaded Volume.

6.	 Select Generate > Display Section(s) > Current to review that data.

7.	 Select File > Save Volume. Save the volume as MRI_3D_Head_bin.

8.	 Click the Erode button [B]. In the Step 2: Erode window, change the Element Depth to 
3 and change the value Iterations to 2. Click Erode Volume (figure 2).

9.	 In the Step Editor window, click Transform Volume. A dialogue box will be returned, 
select Yes.

10.	 Click Connect [C]. Change Max. No. of Components to 1. Click Connect Volume. 

11.	 In the Step Editor window, click Conditional Dilate [D]. In the Conditional window, 
change Element Depth to 3 and change Iteration to 1. Next load the conditional 
volume by clicking the Volume button. Use the window returned to select the MRI_3D_
Head_bin.avw data set saved in step 7. Press the Cond. Dilate Volume button.

12.	 To view your segmentation, select Generate > Display Section(s) > Current (figure 3).

13.	 The binary segmentation is available in the Analyze workspace. To obtain a suitable 
volume for further analysis multiply the binary volume by the input grayscale volume 
using the Image Calculator or Image Algebra modules.

14.	 When you are finished reviewing, close all windows related to the Morphology module 
before proceeding to the next module.

note	 Notice the left side of the Step Editor window; 
as operations are selected from below the 
Morph Operations, the sequence of steps is 
maintained on the left.

Exercise 30 : Morphology Morphological-Based Segmentation
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The goal of this exercise is to demonstrate how to automatically strip the skull from in a T1- or T2-weighted MRI scan.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Watershed module (Segment > Watershed).

3.	 The Watershed module default parameters usually allow for a successful 
segmentation of the brain.  Check the Always Display option and view the red pixels 
that define the ‘Pre-Fill’ level on different slices and orientations.  Do not change the 
Pre-Fill Value (49).

4.	 Click Watershed Segment Volume to initialize the automatic segmentation.

5.	 After the automatic segmentation process has completed, the Results tab is 
automatically selected (figure 1).  Each segmented object will appear as a different 
random color in the image display.

6.	 With the Render Selected Object option selected, click on the object that represents 
the brain in the image display.  

7.	 The Render Tool will automatically be returned (figure 2), allowing you to review the 
segmented objects from difference orthogonal orientations.  You can also click and 
drag the rendering to a new view in the Render Tool image display.

8.	 Select the Create Masked Volume from Selected Object option from the Results 
tab.  Then, click again on the object that represents the brain.  The Compare window 
that appears allows you to review the original and segmented volume side-by-side, 
slice-by-slice in different orthogonal views.

9.	 The File menu provides options to save the segmented object, the masked volume, 
and an object map of the segmented object.

10.	 Choose File > Save Masked Volume.  In the window returned, set Destination to 
Analyze Workspace and then click Save Volume.  The object clicked on in step 8 
after selecting ‘Create Masked Volume from Selected Object’ will be saved to the 
Analyze workspace.  Click Done to dismiss the Save Masked Volume window.

11.	 Close all windows before proceeding to the next exercise.

Figure 1

Figure 2

Exercise 31 : Watershed Automated Segmentation
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The goal of this exercise is to demonstrate the use of the Scattergram tool in the Multispectral Classification module to illustrate the various 
supervised classifiers in the multispectral measurement space.

1.	 Load the MRI_multi.avw data set from the $:\BIR\images\
TutorialData\MultiSpectralTutorial directory.  This file contains 
a spatially co-registered MRI T1 and T2 volume of the same 
patient.  

2.	 Open the Multispectral Classification module (Segment > 
Multispectral Classification).

3.	 Open the Scattergram window (Samples > Scattergrams). 

4.	 In the Scattergram window (figure 1), move the Slice slider 
bar [A] to slice 14.  The T1 and T2 sections are displayed side-by-side along with 
the scattergram of the pixels.  To increase the image display size, change Single to 
Double in the drop-down menu [B] next to the ‘Slice’ slider bar.

5.	 Select the Closed Trace tool and define a small region of white matter (central brain 
tissue) as class 1 by drawing on the image display.   The paired values found in this 
region are colored red in the scattergram display and on the image displayed in the 
main Multispectral Classification window (figure 2). 

6.	 Select the Curved Line tool and define a small region of grey matter (peripheral brain 
tissue) as class 2.  Make sure to choose ‘class 2’ from the Classes drop-down menu 
[C] before starting the trace.  The paired values will show as green in the scattergram 
and in the image display.  

note	 If you use the Load As module to load 
the data set into Analyze, select ‘Single 
Multivolume’ when prompted.

  tip	 To move a defined region hold <Shift> then click and 
drag the region to the desired location.

Figure 1

Figure 2

Exercise 32 : Multispectral Classification
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7.	 Select the Closed Trace tool and define a small region of cerebrospinal fluid (in the 
central ventricles) as class 3.  

8.	 Click Classify Images.  The Gaussian Scattergram Classifier window will 
automatically be returned (figure 3), click Classify.  Click Done to dismiss the window.

9.	 Choose Scattergram & Classified from the drop-down menu below the far right pane 
of the Scattergram window to view the Gaussian class boundaries derived from the 
samples (figure 4).

10.	 By selecting classifiers other than ‘Gaussian Cluster’ in the Scattergram window 
before clicking Classify Images, other supervised classifiers can be demonstrated on 
the same samples.

11.	 Close the Multispectral Classification module before proceeding to the next exercise.
Figure 3

Figure 4

Exercise 32 : Multispectral Classification
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The Object Extractor module applies thresholding, morphology erosion and dilation, and region growing steps in an attempt to automatically 
segment an object within a volume.  This exercise will demonstrate how to use this module.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Object Extractor module (Segment > Object Extractor).

3.	 Open the Define Region window (Generate > Define Region) to begin the 
segmentation process.  

4.	 To define an auto trace on any slice of the volume, first specify a starting slice using the 
‘Slice’ slider bar.  Slice 141 is an excellent starting point for this data set.  Note that the 
orientation can be changed using the Extract Options directly below the slider bar.  

5.	 In order to define a threshold range for the auto trace, a seed point must be set.  Position 
the cursor near the center of the brain and click to set a seed point.  

6.	 The Define Region window will automatically update (figure 1) to display auto trace 
parameters.  Use the double-ended slider bar [A] now 
available to set the Threshold Minimum to 49 and the 
Maximum to 140.

7.	 Click Extract Object to start the object extraction 
process.  The grayscale copy of the extracted object 
will automatically be saved to the Analyze workspace.  

8.	 Once the process is complete, a rendering of the extracted object will be displayed in 
the main Object Extractor window.  The Render Tool will also automatically be returned, 
allowing you to view the object from different orientations (figure 2).

9.	 The resulting extraction can be further examined in the Compare window (Generate 
> Compare).  The Compare window will allow the user to compare the original and 
segmented volume slice-by-slice.  

10.	 If the extraction is not satisfactory, the data may be re-segmented by clearing the regions 
in the Define Region window (Generate > Define Region) and selecting a new seed 
point and threshold range.  

11.	 Close the Object Extractor module before proceeding to the Additional Tasks.

note	 Click the Clear Regs button [B] at 
any time to remove all traces and 
limit ranges. A new starting slice 
may also be defined if required by 
clicking the Target Slice button [C]. Figure 1

Figure 2

Exercise 33 : Object Extractor Automated Brain Segmentation
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As introduced in earlier exercises, an object map is a special image file used by Analyze to 
partition and identify structures as belonging to a particular segmented object.  Voxels in the 
image volume correspond directly, on a one-to-one basis, with a voxel in the object map, 
whose value assigns the voxel to a particular segmented object.  Since object map files can 
also be loaded into other Analyze modules, the same objects within an image volume can be 
referenced for a variety of purposes (see Exercise 47: Region of Interest Measuring Objects in 
Object Maps).  This exercise will demonstrate how to create an object map in Object Extractor.

1.	 Select the MRI_3D_Head.avw data set loaded in the Analyze workspace and 
open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point.  Set the Threshold Minimum to 49 
and the Maximum to 140.

4.	 Click Extract Options and set the Result to Object (figure 1).  A dialog box 
will be returned asking if you would like to create an object map, click Yes 
(figure 2).  Click Done to dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the object 
extraction process.  

6.	 Once the extraction process is complete the object will be displayed overlaid 
on the original image data in the main Object Extractor window (figure 3).  
The Render Tool will also automatically be returned, allowing you to view the 
object from different orientations.

7.	 The object map will not be automatically saved, if you wish to save the object 
map choose File > Save Object Map.

8.	 Close the Object Extractor module.  To learn how to create a binary object 
with the Object Extractor proceed to the next Additional Task.

33.1 Extract Options - Creating an Object Map

Figure 1

Figure 2

Figure 3
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Exercise 33 : Object Extractor Automated Brain Segmentation



Analyze 10.0 Essential Training Guide 92

Occasionally it is necessary to save the segmented object as a binary object, as opposed to a 
grayscale object like in the first part of this exercise.  This additional task will demonstrate how 
to achieve this.  

1.	 Select the MRI_3D_Head.avw data set in the Analyze workspace and then 
open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point.  Set the Threshold Minimum to 49 
and the Maximum to 140.

4.	 Click Extract Options and set the Result to Binary (figure 1).  Click Done to 
dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the object 
extraction process.  

6.	 Once the process is complete, a rendering of the extracted object will 
be displayed in the main Object Extractor window.  The Render Tool will 
automatically be returned again, allowing you to view the object from different 
orientations.  The segmented binary brain will be automatically saved to the 
Analyze workspace and can now be used with any other Analyze module.

7.	 Close the Object Extractor module before proceeding to the next Additional 
Task.

33.2 Extract Options - Creating a Binary Object

Figure 1
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Exercise 33 : Object Extractor Automated Brain Segmentation
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The Object Extractor module now provides the option to automatically remove the brain 
stem from your segmented brain. This task will demonstrate how to segment and remove 
the brain stem.

1.	 Select the MRI_3D_Head.avw data set in the Analyze workspace and then 
open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point. Set the Threshold 
Minimum to 49 and the Maximum to 140.

4.	 Click Extract Options and set the Remove Stem option to On 
(figure 1). Click Done to dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the 
object extraction process.

6.	 Once the process is complete, a rendering of the extracted brain 
with the brain stem removed will be displayed in the main Object Extractor 
window. The Render Tool will also automatically be returned (figure 2), 
allowing you to view the object from different orientations. The segmented 
grayscale brain will be automatically saved to the Analyze workspace and can 
now be used with any other Analyze module.

7.	 Close the Object Extractor module before proceeding to the next exercise.
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33.3 Extract Options - Automatic Brain Stem Removal

Figure 1

Figure 2

Exercise 33 : Object Extractor Automated Brain Segmentation
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The Object Extractor module supports the creation of multi-object object maps. This exercise will demonstrate how to achieve this. 

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Object Extractor module (Segment > Object Extractor).

3.	 Open the Define Region window (Generate > Define Region) to begin the 
segmentation process.  

4.	 To define an auto trace on any slice of the volume, first specify a starting slice using 
the ‘Slice’ slider bar.  Slice 104 is the default slice, and it is an good starting point for 
this data set. 

5.	 Position the cursor near the center of the left lung and click to set a seed point.  

6.	 The Define Region window will automatically update (figure 1) to display auto trace 
parameters. Use the double-ended slider bar [A] now available to set the Threshold 
Minimum to 18 and the Maximum to 99.

7.	 Click the Extract Options button, and set the Result to Object (figure 2), select Yes 
in the window returned.

8.	 In the Define Regions window, click Extract Object to start the object extraction 
process.  The left lung will be extracted and saved as the object called ‘Extracted’. 
The object will appear red.

9.	 Open the Define Regions window again, when opened click the Clear Regions button 
[B]. Next, click in the right lung to set a seed point, set the Threshold Minimum to 18 
and the Maximum to 104. 

10.	 Click Extract Object again. The right lung will be extracted and saved as the object 
called Extracted (2), the object will appear green. In the main Object Extractor 
module you will see both lungs (figure 3). 

Figure 1

Figure 2

Figure 3

Exercise 34 : Object Extractor Extracting Multiple Objects
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11.	 The render window will now display both lungs in 3D (figure 4). 

12.	 To change the name and color of each object, go to the Objects window (View > 
Objects). Set Control By to Attribute, and from the drop down menu select the 
Name and Color attribute options (figure 5).

13.	 To save the object map for use in other modules, select File > Save Object Map.

14.	 Close all windows related to the Object Extractor module before proceeding to the 
next exercise.

Figure 4

Figure 5

Exercise 34 : Object Extractor - Extracting Multiple Objects
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Polygonal surface extraction is the process of converting an object in the voxel-based volume to a representation of the surface of the object, 
expressed as sets of vertices and polygons.  This conversion must optimally extract a representative surface, with as much detail as possible, but do 
so with as few vertices and polygons as possible.  This exercise will use the Adapt/Deform algorithm to perform such an optimal surface extraction.  
Often this surface extraction is a precursor to using the surface with other applications, such as CAD/CAM modeling, rapid prototyping (model 
building), and finite element analysis. 

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map.

4.	 Open the Extraction Parameters window (Generate > Extraction).

5.	 Click Objects [A] at the top of the Extraction Parameters window (figure 1).  In the 
window returned, leave the Brain set to On and set all other objects to Off.  Click 
Done to dismiss the window.

6.	 Create a polygonal surface of the ‘Brain’ object using the Adapt/Deform algorithm with 
the default parameters.  With the AdaptDeform tab selected click Extract [B].

7.	 A dialog box will be returned stating the number of polygons generated.  Note the 
number of polygons (approximately 37,258), then click Done.

8.	 To create a rendering of the surface model, choose Generate > Render.  A surface 
map will automatically be created for the ‘Brain’ surface, and the Surfaces window 
returned.  The rendering will be displayed in the main Surface Extractor window 
(figure 2).

9.	 In the Extraction Parameters window change the Cube Edge Size [C] to 5 and 
rebuild the surface by clicking Extract.  Note, the number of polygons generated 
(approximately 12,261), then click Done.  

10.	 Choose Generate > Render to view the extracted surface with the new parameters 
(figure 3).  Increasing the ‘Cube Edge Size’ will smooth the surface, reducing the 
number of voxels considered when generating the initial surface estimate, which 
reduces the polygon count.  

Exercise 35 : Surface Extractor Polygonal Surface Extraction
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11.	 Click Reset [D] in the Extraction Parameters window to restore the default parameters 
(‘Cube Edge Size’ of 3).

12.	 Click Advanced [E] and change the Time Step to 0.5.  Click Done to dismiss the 
window.

13.	 Rebuild the surface by clicking Extract in the Extraction Parameters window.  Note 
the number of polygons generated (approximately 37,258), then click Done.  

14.	 Choose Generate > Render to view the extracted surface with the new parameters.  
Increasing the ‘Time Step’ causes the surface extraction to reach equilibrium faster, 
producing a smoother surface without altering the polygon count.  When the opposite 
changes are made, the surface will conform to the voxel surface better, resulting in a 
rougher, more “voxelated” surface.

15.	 Decreasing the Surface Force and increasing the Spring Constant (also ‘Advanced’ 
options) smooths the surface without altering the polygonal count by forcing the 
polygons to bridge small variations in the voxel surface (the polygon’s attraction to the 
surface is reduced and they become harder to bend). 

16.	 Press the Save Surface PowerBar button or choose File > Save Surface > To File to 
save the extracted surface to disk.  

17.	 In the Save Surface window returned (figure 4) you can select from the following 
surface description formats in the Format drop-down menu: Alias (.obj), Autocad 
(.dxf), Compressed Iges (.iges), Iges (.iges), Inventor (.iv), Patran (.out), Poly (.poly), 
3D Systems (.stl), Binary 3D Systems (.stl), Vrml (.wrl).

18.	 Close the Surface Extractor module.  To learn about extracting the surface of a binary 
data set, complete the following Additional Task.

note	 Increasing the resolution increases the processing time, this is demonstrated 
by setting the ‘Cube Edge Size’ to ‘1’.  In cases where a high resolution (Cube 
Edge Size of 1) is required, use the Marching Cubes algorithm.

Exercise 35 : Surface Extractor Polygonal Surface Extraction
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1.	 Load the MRI_3D_Brain_Bin.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Open the Extraction Parameters window (Generate > Extraction). 

4.	 With the AdaptDeform algorithm tab selected, click Extract.

5.	 Note the number of polygons generated (approximately 37,504) and choose 
Generate > Render to view the extracted surface (figure 1).

6.	 Close the Surface Extractor module before proceeding to the next exercise.

Polygonal Formats
Alias Wavefront	 (.obj) Read and Write
Autocad 	 (.dxf) Read and Write
IGES	 (.iges) Write only
Compressed IGES 	 (.iges) Write only
Inventor 	 (.iv) Write only
Patran	 (.out) Write only
Poly	 (.poly) Read and Write
Binary 3D Systems	 (.stl) Raad and Write
VRML	 (.wrl) Write only

Contour Formats
HP 3D	 (.hpgl) Write only
IGES	 (.iges) Write only
Compressed IGES	 (.iges) Write only
Pogo 	 (.slc) Read and Write
3D Systems Stereolithography	 (.slc) Read and Write
ASCII Columns	 (.txt) Read and Write

Supported Surface File Formats
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35.1 Extracting the Surface of a Binary Data Set

Exercise 35 : Surface Extractor Polygonal Surface Extraction
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Contour surface extraction is the process of converting an object in the voxel-based volume to a representation of the surface of the object, 
expressed as a series of stacked contours.  This surface extraction is a precursor to other applications, such as CAD/CAM modeling, rapid 
prototyping (model building), and finite element analysis.  This exercise demonstrates how to use the Contours algorithm.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map.

4.	 Open the Extraction Parameters window (Generate > Extraction).  

5.	 Click Objects [A] at the top of the Extraction Parameters window (figure 1).  In the 
window returned, switch the Ventricle to On and set everything else Off.  Click Done 
to dismiss the window.

6.	 Create a contour surface of the ‘Ventricle’ object using the Contours algorithm with the 
default parameters.  Select the Contours tab and click Extract.

7.	 A dialog box will be returned stating the number of slices for which contours were 
generated.  Note the number of slices used (60), then click Done.

8.	 To create a rendering of the extracted contour model, choose Generate > Render.  

9.	 In the Extraction Parameters window, click Advanced [B] in the ‘Contours’ tab.  Check 
the Subvolume Extraction option and click Done to dismiss the window (figure 2).  

10.	 Rebuild the contour surface by clicking Extract in the Extraction Parameters window.  
Note the number of slices used (108).  This resamples and reformats the object and 
thus changes the number of slices.

11.	 Choose Generate > Render to create a rendering of the extracted contour model 
(figure 3).  

12.	 Close the Surface Extractor module before proceeding to the next exercise.  
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Exercise 36 : Surface Extractor Contour Surface Extraction


