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The DICOM Tool expands DICOM support in Analyze, enabling the indexing of collections of DICOM images through a local database file. This 
exercise will demonstrate how to create a database and then how to import DICOM data into the database.
Note: If you are a previous BirPacs user please contact support@analyzedirect.com for instructions on migrating your database to the DICOM Tool.

1.	 Open the DICOM Tool (File > DICOM Tool).

2.	 The DICOM Tool will detect that there is no database present; a dialog box will be 
returned asking you if you would like to create a new database or browse for an 
existing database, click Create a new local database.

3.	 The Create New Image Database window (Figure 1) allows you to specify a 
database name and file system directory, configure a DICOM receiver for the 
database (optional), configure a database server (optional), and specify the source of 
initial DICOM images (optional).

4.	 The Local Database Name will default to ‘SystemName_PortNumber’; chance the 
Local Database Name to TEST_5679 [A].

5.	 On your system’s local disk create a folder called ‘AnalyzeDB’ ($:/AnalyzeDB)

6.	 Click the Local Database Directory button in the Create New Image Database 
window.

7.	 In the Browse for Folder window returned navigate to the location of the new 
‘AnalyzeDB’ folder ($:/AnalyzeDB), select the folder, and click OK. You have now 
specified the location of your local database [B].

8.	 To create the local database click the Create Local Database button [C].

9.	 Once the database has been created a dialog box will be returned stating ‘All Done’, 
click OK.

note	 If this is not the first time you have accessed the DICOM Tool, you can access the 
Create New Image Database window by selecting File > Create Database.

Figure 1

Exercise 1 : DICOM Tool Quick Configuration
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10.	 To import DICOM data into the DICOM Tool right-click anywhere in the white space 
and select Import DICOM Images from the menu (Figure 2). Alternatively, select File 
> Import DICOM Images.

11.	 In the Browse for Folder window returned navigate to and select the folder $:\BIR\
images\TutorialData\ImportExportTutorial, then click OK.

12.	 A dialog box will be returned asking you to confirm that you would like to ‘Import all 
DICOM files found below <C:/BIR/images/TutorialData/ImportExportTutorial>’, click 
Yes to confirm.

13.	 All 121 DICOM images contained within the folder will be copied into the database. 
The DICOM Tool will automatically sort and index the data by patient, study, series, 
and volume.

14.	 Data can be selected and viewed in the DICOM Tool (Figure 3). To load a selected 
data set into the Analyze workspace click Load Volume [D]; if you wish to resize or 
resample the data click Load As, this will load the selected data into the Load As 
module (see exercise 4 for instructions on how to use the Load As module).

Figure 2

Figure 3

Exercise 1 : DICOM Tool Quick Configuration
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The DICOM Tool expands DICOM support in Analyze, enabling the indexing of collections of DICOM images through a local database file. With the DICOM 
Tool, databases can be created, updated, and shared with other users with file system access to the images and the database file. This exercise will 
demonstrate how to create a database, configure a DICOM receiver and Database sender and then how to import DICOM data into the database.
Note: If you are a previous BirPac user please contact support@analyzedirect.com for instructions on migrating your database to DICOM tool.

1.	 Open the DICOM Tool (File > DICOM Tool).

2.	 If you have already completed exercise 1, choose File > Create Database. If the 
DICOM Tool detects that no database is present, a dialog box will be returned asking 
you if you would like to create a new database or browse for an existing database, 
click Create a new local database.

3.	 In the Create New Image Database window you can specify the database name and 
file system directory, specify a DICOM receiver for the database (optional), specify 
database server (optional), and specify the source of initial DICOM images (optional).

4.	 The Local Database Name will default to ‘SystemName_PortNumber’; change the 
Local Database Name to TEST2_5679.

5.	 The Local Database Directory option enables you to specify the directory on your 
system in which the database and all of the DICOM images will be stored.

note	 Any name can be chosen for the local database, however when creating multiple 
databases, following a coherent naming convention will simplify database management.

i.	 On your system’s local disk create a folder called ‘AnalyzeDB’ ($:/AnalyzeDB). 
Note that if you have completed exercise 1, DICOM Tool - Quick Configuration, 
this 	 folder should already exist.

ii.	 Once the directory has been created, click Local Database Directory [A] in the 
Create New Image Database window, and navigate to the location of the new 	
‘AnalyzeDB’ folder ($:/AnalyzeDB).

iii.	 Select the folder and click OK. You have now specified the location of your 			 
database.

Figure 1

Exercise 2 : DICOM Tool Advanced

Specification of the Database Name and Directory



Analyze 10.0 Essential Training Guide 17

6.	 The Configure DICOM Receiver option allows you to configure a DICOM receiver for 
the database.  This step is optional, if you do not want to configure the receiver please 
move on to step 8, otherwise check the Configure DICOM Receiver option [B].

7.	 DICOM Receiver configuration requires three key pieces of information:  the Receiver 
AET, the Receiver Port on the local system, and the directory where the DCMTK 
executable programs are installed.

i.	 DICOM Receiver AET: By default is set to ‘SystemName_PortNumber’.  To 
reflect the receiver’s connection to the database defined in step 4, change the 
DICOM Receiver AET to TEST2_5679.

ii.	 DICOM Receiver Port: Specifies the TCP/IP port number on which the DICOM 
Receiver listens for connections to receive messages.  For this exercise, the 
DICOM Receiver Port can remain 5679.

iii.	 DCMTK Path: The DCMTK executable files are automatically installed with 
Analyze in the $:\BIR\DCMTK-3.5\$System_Type$\bin directory (where 
$System_Type$ is your system platform, e.g. PC_NT) and the DCMTK Path will 
point to this directory by default.  However, if Analyze is being run from a network 
rather than local installation, the DCMTK files should be installed locally and this 
path should point there.

Specification of a DICOM Receiver (optional)

Exercise 2 : DICOM Tool Advanced
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8.	 The Configure Database Server option allows you to configure an optional database 
server to manage automatic updates and multiple client access to the database over 
a network.  The database server is a dedicated process attached to one database and 
accessible by system name and port number.  It responds to connection requests, 
SQL statements, and requests for images, and polls the image storage area for newly 
received images to register.  Configuring and installing a database server is very 
similar to configuring the DICOM receiver.  This step is optional, if you do not want 
to configure the database server please move on to step 10, otherwise check the 
Configure Database Server option [C].

9.	 The Database Server fields are used to configure the database server process that 
controls access to the database.

i.	 Service Name: The name by which the servicer is identified, for this exercise 
use TEST2_5679.

ii.	 Host System: Identifies the system name this program is running on. You can 
create servers to run on your system, and any server should be attached to a 
database local file system. 

iii.	 Port Number: Specifies the port number client systems will use to connect to 
server.  It cannot be the same port as the one used by the DICOM receiver 
(STORESCP).  For this exercise set the port to 5680.

iv.	 Update Frequency: Specifies the interval in minutes at which the server will poll 
the image storage directory to see if the DICOM receiver has deposited images 
to be in the database.  For this exercise, you can leave this set to 5.

v.	 Server Logging: Creates a log file of the database server for diagnostics.  

note	 On Windows systems this becomes the name of the Windows Service; on UNIX 
systems it is used to name the daemon script which starts, stops and checks 
server status.

  tip	 It is recommend using a closely related port 
number so they can be easily remembered; 
e.g., if the receiver is running at port n, run 
that database server at port n+1.

Specification of a Database Server (optional)

Exercise 2 : DICOM Tool Advanced
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10.	 The Source of Initial Images option allows you to specify a directory containing 
DICOM images; click Source of Initial Images [D].

11.	 In the Browse for Folder window returned, navigate to the $:\BIR\images\
TutorialData directory, select the ImportExportTutorial folder, and click OK.

12.	 To create the local database, click Create Database Server [E].  Note, creating a 
Database Server requires administrative privileges; a dialog box will automatically be 
returned stating that you will receive a prompt from your operating system, click OK.  
You will then need to enter the administrator password.

13.	 The DICOM Tool will now copy the DICOM images from the initial source to the 
location (if selected) specified in step 5. The data will automatically be sorted and 
indexed by patient, study, series, and volume. 

14.	 Once the process is complete, the Create New Image Database window will 
automatically be dismissed and the data will now be available in the DICOM Tool 
(figure 2).

15.	 Data can be selected from the Patient information panel [F] in the DICOM Tool. 

16.	 Select the data set with the ‘Patient Name’ MR SIGNA LX 1.0T and ‘Patient ID’ 337.  
The data set will be highlighted, note the other information panels will automatically 
update with relevant Study, Series, and Volume information (when available).  

17.	 Note there are two data sets available for selection in the Series information panel [G] 
below.  Select Series 102.  

Figure 2

Viewing and Loading Data

Creating the Database Server

Specification of the Source of Initial Images (optional)

Exercise 2 : DICOM Tool Advanced
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18.	 Review the data slice-by-slice by using the Slice Number slider bar under the image 
display.  

19.	 Right-click on the image display to open the Intensity window (figure 3).  Here you 
can change the intensity display of the image; use the slider bar to take the Maximum 
intensity level down to 500.  The image display will interactively update.  Click Done to 
dismiss the Intensity window.  

20.	 To load this data set into the Analyze workspace, click Load Volume.  The data set 
will automatically load into the Analyze workspace.

21.	 Move the cursor over any of the information panels and right-click.  The menu 
returned provides most of the options available for management of the images in the 
DICOM database, these options include:

Refresh: Deselects any selected data and refreshes the data
Configure Columns: Configure the column properties for the data display
Configure Search: Focus the scope of the displayed data with an information 		
	 search
Show Server Info: Enable/disable display of recent databases and remote AETs
Update DB: Register any recently received unregistered images in the database
Query Current AET: Perform query retrieve on remote AET to retrieve images
DB Update Status: Enable/disable display of Database Update Status
Import DICOM Images: Copy and register images from the file system to the 		
	 database
Load Patient: Load patient data from files
Export Patient: Export patient data to files
Delete Patient: Delete the patient data from the database
Send Patient: Send patient data to listening server
Anonymize Patient: Anonymize the patient information (only available from the 	
	 patient pane)

note	 If you wish to resize or resample the data 
use the Load As button option, this will 
load the selected data into the Load As 
module (see exercise 4 for instructions on 
how to use the Load As module).

Figure 3

Other DICOM Tool Options

Exercise 2 : DICOM Tool Advanced
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22.	 On your system’s local disk create a folder called ‘test_export’ ($:/test_export).

23.	 Select the ‘Patient Name’ MR dataset Brain and then right-click and select the 
Export Patient option (figure 4).  

24.	 In the Browse for Folder window returned, navigate to and the new ‘test_export’ 
directory, then click OK.  The DICOM images will be exported out to this directory.  

25.	 Now navigate to the ‘test_export’ directory on your system’s local disk; note the file 
names have changed to new DICOM UIDs.

26.	 In the DICOM Tool, with MR data set Brain still selected, right-click and select the 
Delete Patient option.  

27.	 A dialog box will be returned asking you to confirm that this is what you want to do, 
click Yes.  A delete confirmation window will be returned, click OK to dismiss it.

28.	 To import this data back into the DICOM Tool right-click in any of the information 
panels and select the Import DICOM Images option.  In the window returned 
navigate to and select the ‘test_export’ directory on your system disk, then click OK.  

29.	 You will be asked if you would like to ‘Import all DICOM files found below 
<$:/test_export >’, click Yes to import these images back into the database.  The data 
will be automatically sorted and imported into the DICOM Tool database, and the data 
set will appear in the Patient information panel.

30.	 Close the DICOM module before proceeding to the next exercise.

  tip	 Multiple databases can be created for the DICOM Tool, so multiple DICOM 
receivers can be configured for the tool; you can select different databases 
from the Local Databases drop-down menu option.

Figure 4

Exercise 2 : DICOM Tool Advanced
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Analyze supports over 45 different file formats. By default, only the most common formats are enabled. The Import/Export module’s External 
Libraries tool can be used to enable and disable these formats. This exercise will show you how to use the External Libraries tool to switch on 
support for additional formats.

1.	 Open the Import/Export module (File > Import/Export).

2.	 To view the file formats currently supported in Analyze, choose Help > Formats.

3.	 File formats currently supported are listed in the bottom ‘Formats’ section of the 
Supported Formats window (figure 1).  When a format is selected, the associated 
properties will automatically become checked in the ‘Properties’ section of the 
window.  Experiment by checking several different formats and noting their properties.  
Click Done to dismiss the window.

4.	 Open the External Libraries tool (Tools > External Libraries).  

5.	 The External Libraries tool provides a graphical interface listing all formats supported 
by Analyze (figure 2). The green and red status indicators note whether a format is 
currently ‘Loaded’ (L) and ‘Configured’ (C) - green indicating yes and red indicating 
no.

6.	 If you wish to switch on support for a specific file format (for example, PICKERMRI), 
click on the format in the External Libraries tool.  A Configure ‘X’ Format window will 
be returned (where ‘X’ is equal to the selected format) (figure 3).

7.	 In the Configure ‘X’ Format window, click Load Now to change the ‘Currently Loaded’ 
status to a green Yes.

note	 Users running multiple operating systems need to configure support for each file format 
for each operating system. The ‘Platforms’ option allows the format to be configured for 
all operating systems (ALL) or for a specific operating system (SPECIFIED).

Figure 1

Figure 2 Figure 3

Exercise 3 : Switching On Support for Additional Formats



Analyze 10.0 Essential Training Guide 23

8.	 Click OK.  A dialog box will be returned stating that your ‘EXTEND.conf’ file will be 
updated, click OK (figure 4).  The format is now supported by Analyze.

9.	 If you would like to load and configure all supported formats for your system, click 
Max in the External Libraries tool.  All image file formats will now be supported by 
Analyze.  The ‘L’ and ‘C’ status indicators will appear green next time you open the 
External Libraries tool (figure 5).

10.	 Click Done to close the External Libraries tool.

11.	 Close the Import/Export module before proceeding to the next exercise.

note	 Each file format enabled increases the amount of memory used by your system; it 
also increases the time taken for a module to open. However, this is typically only 
an issue on older systems or systems where memory resources are scarce.

Figure 4

Figure 5

Exercise 3 : Switching on Support for Additional Formats
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Analyze
AnalyzeAVW	 used internally for memory mapping, supports all data 

types, 2D, 3D, and 4D.
UNKNOWN 	 enables reading raw binary data into images, and 	

exporting image data as raw.
VolumeFile	 enables lists of 2D files to be used as a 3D entity
OBJMAP 	 enables object maps to be treated as regular images
ANALYZEIMG 	 old Analyze 7.5 format, i.e. .hdr & .img pairs
ANALYZESCRN 	 old Analyze 7.5 format of old Screen Edit program

Raster
BMP 	 Microsoft Windows Bitmap
GIF 	 a common color indexed format
JPG 	 common format featuring lossy compression
PBM 	 ascii and binary formats used in Portable Bitmap 

Library
PGM 	 grayscale Portable Bitmap Library
PPM 	 24 bit Color Protable Bitmap Library
PIC 	 format used by Softimage
PNG 	 Portable Network Graphics
PS 	 output to a PostScript raster dump
SGI 	 format used by Silicon Graphics
SUNRASTER 	 format used by Sun Microsystems
TARGA 	 a common color format
TIFF 	 tagged information file format, a common format
XBM 	 an ascii ‘c programming language’ format used by the 	

X Windows system
XWD 	 X Windows dump

Video
QUICKTIME 	 common movie format
YUV 	 single frame color video format
AVI 	 video format used by Microsoft Windows
MPEG1	 standard movie format

Standard Radiological File Formats
DICOM 	 the standard medical image file format based on 

Mallincrodt ctn_3_0_3.
ACR/NEMA 	 precursor to DICOM
PAPYRUS2 	 3D extensions to DICOM from OSIRIS
PAPYRUS3 	 3D extensions to DICOM from OSIRIS
NIfTI	 Neuroimaging file format

Vendor-Specific Radiological File Formats
GE9800 	 older CT format
GEADVANCE 	 Advance, nulcear medicine format
GEADVANTAGE	 format for CT and MRI
GESIGNA 	 older MRI format Signa 4.x
GESTARCAM 	 older PET format
INTERFILE 	 a standard format for nuclear medicine
PICKER MRI 	 old MRI format used by Picker
SIEMENSCT 	 old Siemens CT format Somatom DR3
SIEMENSMAGVIS 	 Siemens Magnetom Vision (MRI format)
CTI	 PET format used by CTI, early version of ECAT7
7CTI 	 PET format used by CTI; CTIECAT7
IMATRON 	 proprietary CT format
SMIS 	 proprietary MRI format
BRUCKER MRI	 proprietary MRI format
BIO RAD	 proprietary format
VARIAN FDF	 Varian MRI format

Supported File Formats

Exercise 3 : Switching on Support for Additional Formats
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Scanner acquired data is rarely isotropic (cubic) which means that the voxel width, height, and/or depth have different sizes (most often a different slice 
thickness than the in-plane resolution).  This exercise will demonstrate how to load an anisotropic (non-cubic) volume image with the same resolution as when 
acquired, and then load it again to resize the volume image to create an isotropically sampled volume (cubic) for further use in Analyze.

1.	 Open the Load As module (File > Load As).

2.	 Click File [A] and navigate to and select the MRI_Head.avw data set in the 
$:\BIR\images\TutorialData directory.

3.	 Uncheck the Auto Exit After Load option [B] and click Load.  The data will be loaded into 
the Analyze workspace as it was acquired (anisotropic).

4.	 To load the data as isotropic (cubic), select the Resize tab [C] (figure 1).

5.	 Check the Force Cubic option [D] and click Load; the data will be resampled at the cubic 
resolution and then loaded.  The highest spatial resolution in the acquired volume image is 
used as the cubic resolution for resampling.

6.	 Two volumes are now loaded into the Analyze workspace, ‘MRI_Head’ and ‘MRI_Head0’.  
The latter volume is the cubic volume.  To examine the effects of this isotropic sampling, 
proceed to Exercise 8: Multiplanar Sections.

7.	 If a specific cubic voxel resolution is desired, the voxel size can be changed.  To set the 
output voxel dimension to 1.5 mm, enter 1.5 in the Output Voxel Size field [E] and press 
<Enter>.  Notice that the ‘Output Axis Dimensions’ and ‘Memory’ fields automatically adjust 
when the voxel dimension is changed.

8.	 It is also possible to set a specific dimension for the resulting volume image.  For example, 
if you wanted an output volume with an X dimension of 200, enter 200 in the Output X Axis 
Dimension field [F] and press <Enter>.  Again, the other parameters will automatically 
adjust.

9.	 You may encounter data sets that are too large to be accommodated by the computer on 
which you are running (usually due to memory limitations), particularly at the resampled 
cubic resolution.  Specifying a maximum memory size while the Force Cubic option is 
checked forces each parameter to adjust to the largest value possible that still fits within the 
specified memory size.  Enter 16 into the Output Memory Mb field [G].

10.	 Close all windows related to the Load As module before proceeding to the next exercise.

Figure 1

Exercise 4 : Load As Loading and Resizing Anisotropic
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Occasionally it is necessary to import raw data or image data of an unknown file format into Analyze.  Such data can be imported if pixels are 
uncompressed and in contiguous images within the file.  The Raw Data tool provides several interactive options to view data as images, ASCII 
strings, or as the actual binary values of bytes and words.  Data can be directly loaded into Analyze or converted into Analyze format image files.  
Most image file formats consist of some initial header information describing the image(s) and the actual image data. This exercise will demonstrate 
how to convert raw data from a scanner, which currently has no direct file format support in Analyze.

1.	 Open the Import/Export module (File > Import/Export).

2.	 Open the Raw Data tool (Tools > Raw Data). 

3.	 With the Files tab selected, click the File button under ‘Input’ (figure 1).

4.	 In the Import/Export – Input File window returned navigate to the $:\BIR\
images\TutorialData\ImportExportTutorial directory and select the file 
UNKNOWN1.

5.	 Select the Image Parameters tab (figure 2). 

6.	 For this exercise, assume that we know that this file contains one 256 
x 256 image, a signed 16-bit integer.  An image of this size requires 
131072 bytes of storage (256 x 256 x 2), however the file size is 
137210 bytes.  This indicates that there is an additional 6138 bytes of 
header information present.  This needs to be skipped to get to the first 
byte of image data.  Finally, we know that the 16-bit image data in the 
file is stored in Big-Endian byte format.

7.	 To accommodate this, set the following parameters:   
•	 Byte Offset: 6138 [A](or check ‘Auto Offset’ to compute this 			 

automatically)
•	 Width: 256 [B]
•	 Height: 256 [C]
•	 Data Type: signed 16-bit [D]
•	 Byte Swap: Pairs (this only needs to be set on a little-endian 			

architecture, i.e., PC-based systems) [E]

Figure 1

Figure 2

Exercise 5 : Import/Export Converting Raw Data into Images
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8.	 Check the following Auto options [F]: 
•	 Display: Image display will update anytime a control parameter is 

changed.
•	 Clear: Image display is cleared before a new image is displayed.
•	 Scale: Data is automatically scaled from its entire dynamic range 

to 8-bits for display.

9.	 Click Display to view the current image in the main Import/Export 
window (figure 3).

10.	 Click Load in the Raw Data tool to load the image specified in the 
file into the Analyze workspace.  

11.	 Experiment with the display effects by changing the image 
parameters to incorrect values, use the up and down arrow buttons 
found next to the Width and Height fields.

12.	 Click Done to close the Raw Data tool. 

Figure 3

Exercise 5 : Import/Export Converting Raw Data into Images
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Most medical image formats do not support 3-D directly, since each slice in a study is written to a separate file.  The Volume Tool provides a way to 
create a pseudo format for handling groups of 2-D files as a single 3-D entity.  Analyze uses the AVW_VolumeFile, or volume file (.vol), as a way to 
organize a list of 2-D files into a 3-D volume.  The files must contain images of the same size and data type.  This exercise will show you how to use 
the Volume Tool to create a volume file from a list of 2-D TIFF files.

1.	 Open the Import/Export module (File > Import/Export).

2.	 Open the Volume Tool (Tools > Volume Tool).

3.	 In the Volume Tool, click Wild Cards.  

4.	 In the window returned (figure 1), click Directory and navigate to $:\BIR\images\
TutorialData\VolumeToolTutorial - the directory containing the 2-D TIFF data for this 
exercise. 

5.	 The Filter field is set to * by default so everything in the directory is selected.  As this 
directory only contains TIFF data specific to the data set we wish to load, leave the 
filter as is.  

6.	 Click Apply. The TIFF files will now be copied to the Volume Tool (figure 2).

7.	 In the Volume Tool, click Verify to ensure that all the slices selected are the same size 
and data type.  

8.	 A dialog box (figure 3) will be returned upon successful verification stating ‘Verify 
Succeeds’; click Continue.

9.	 Click Save and save the volume file as TIFF_Head.vol in the $:\BIR\images\
TutorialData directory.

10.	 Close the Import/Export module before proceeding to the next exercise. 

tip	 The volume file saved can now be loaded into Analyze 
using the Load or Load As modules. Alternatively you can 
load the volume file directly into the Analyze workspace 
from the Volume tool by clicking ‘Load’.

Figure 1

Figure 3 Figure 2

Exercise 6 : Import/Export Volume Tool
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At some point it will become necessary for you to save your data out of Analyze.  This exercise will demonstrate how to do this using the Save module.

1.	 Select a data set from the Analyze workspace.  If there is no data loaded, load MRI_
Head.avw from the $:\BIR\images\TutorialData directory.

2.	 Open the Save module (File > Save).

3.	 Click File and navigate to the directory where you would like to save the data set and 
specify a name.  Click Save to return to the main module window. 

4.	 Use the Format drop-down menu to specify the format in which you wish to save the 
data set.

5.	 Click Save to save the data set and close the Save module.

  tip	 You can also save your data out of Analyze using the Save As module.  The 
Save As module provides the same tools as the Load As module, allowing you to 
resize, change orientation, sub-region, and perform other manipulations on your 
data while saving it out of Analyze.

note	 Only formats enabled in the external libraries tool will be available. To switch 
on support for additional formats, please refer to Exercise 3: Switching on 
Support for Additional Formats.

Figure 1

Exercise 7 : Saving Data Out of Analyze


